Печать
PDF

Как зафиксировать ссылку в Excel?

Автор: Алексей Батурин.

фиксируем диапазон в Excel

Очень важно знать для быстрого расчета прогноза в MS Excel — Как в формуле зафиксировать ссылку на ячейку или диапазон?


Это необходимо для того, чтобы, когда вы протягивали формулу, ссылка на ячейку не смещалась. Например, для расчета коэффициента сезонности января (см. вложение) мы средние продажи за январь (пункт 2 см. вложение) делим на среднегодовые продажи за 3 года (пункт 3 см. вложение). Если мы просто протянем ячейку вниз, чтобы рассчитать коэффициенты для других месяцев, то для февраля мы получим, что среднегодовые продажи за февраль разделятся на ноль, а не на среднегодовые продажи за 3 года.

Как зафиксировать ссылку на ячейку, чтобы, когда мы протягивали формулу, ссылка не смещалась?

Для этого в строке формул выделяете ссылку, которую хотите зафиксировать:

Фиксируем ячейку в Excel

и нажимаете клавишу «F4». Ссылка станет со значками $, как на рисунке:

Ячейка зафиксирована

это означает, что если вы протяните формулу, то ссылка на ячейку $F$4 останется на месте, т.е. зафиксирована строка '4' и столбец 'F'. Если вы еще раз нажмёте клавишу F4, то ссылка станет F$4 — это означает, что зафиксирована строка 4, а столбец F будет перемещаться.

зафиксирована строка в Excel

Если еще раз нажмете клавишу «F4», то ссылка станет $F4:

Зафиксирован столбец

Это означает, что зафиксирован столбец F и он не будет перемещаться, когда вы будите протаскивать формулу, а ссылка на строку 4 будет двигаться.

Если ссылки имеют вид R1C1, то полностью зафиксированная ячейка будет иметь вид R4C6:

Ячейка полностью зафиксирована

Если зафиксирована только строка (R), то ссылка будет R4C[-1]

Фиксируем строку в Excel

Если зафиксирован только столбец (С), то ссылка будет иметь вид RC6

зафиксирован только столбец

Для того, чтобы зафиксировать диапазон, необходимо его выделить в строке формул в Excel и нажать клавиши “F4”.

фиксируем диапазон в Excel

Предлагаю вам самостоятельно проделать описанные выше операции, и если будут вопросы, задать их в комментариях к данной статье.

Зарегистрируйтесь и протестируйте Forecast4AC PROскачать программу для прогнозирования Forecast4AC PRO

график модель прогноза + трендграфик сезенностьграфик прогноз + границы прогноза + трендграфик прогноз к предыдущим периодам

Forcast4AC Pro 4ddabd6bbee26 250x250Подписка "Прогноз с точностью 90% и выше!"

Присоединяясь к нам Вы получаете:

  • Более 10 рекомендаций по прогнозированию продаж!
  • Практические примеры!
  • Ссылку на Forecast4AC PRO - 40 дней бесплатно!
  • + советы по работе с программой!

Forecast4AC PRO - прогноз одним нажатием клавиши!

Статья полезная? Поделитесь с друзьями

Ваши комментарии и вопросы:

Comments  

 
#31 Алексей Батурин 15.01.2016 21:09
Цитирую Богдан:
про фиксирование ячейки, столбца и строки понятно. Есть необходимость немного в другом.
Я прописываю, скажем, а1=а2+а3
затем добавляю колонку между первой и второй
формула в а1 автоматически преобразовывается в =а3+а4
Как заставить ее не изменяться, а запомнить, что мне нужно именно а2+а3


Богдан, здравствуйте.
Вашу задачу можно решить с помощью формулы =ИНДЕКС()
Для обозначенных вами ячеек а2+а3 необходимо сделать запись:
=ИНДЕКС(A2:A4;1;1)+ИНДЕКС(A2:A4;2;1)
Теперь при вставке строки во внутрь диапазона A2:A4, диапазон в формуле ИНДЕКС расширится, но ссылка будет ссылаться на указанные в формуле ИНДЕКС - номер строки и столбца, внутри заданного диапазона A2:A4.
Quote
 
 
#30 Богдан 15.01.2016 18:53
про фиксирование ячейки, столбца и строки понятно. Есть необходимость немного в другом.
Я прописываю, скажем, а1=а2+а3
затем добавляю колонку между первой и второй
формула в а1 автоматически преобразовывает ся в =а3+а4
Как заставить ее не изменяться, а запомнить, что мне нужно именно а2+а3
Quote
 
 
-1 #29 Алексей Батурин 23.12.2015 13:24
Цитирую Ирина:
В добавок к предыдущему вопросу,
сейчас прочитала первый комент, и вы советуете не использовать инструмент таблицы, и писать обычным диапазоном А$1$, а мне именно хочется, что бы в формуле было не имя ячейки/диапазона (сумм(А$1$:А$4$)), а именно прописана суть (что как раз достигается если оставить, например =СУММЕСЛИ(Планпродаж[Код клиентской группы];[@[Код клиентской группы]];Планпродаж[март]), что бы при протягивании на апрель, он мне так и оставлял Планпродаж[Код клиентской группы], а не переходил на Планпродаж[Столбец1].
Спасибо

Ирина, можно нужному диапазону присвоить "Имя", и в качестве ссылки подставлять "имя", тогда будет понятна суть.
Как присваивать имена диапазонов есть в этой статье: http://www.4analytics.ru/prognozirovanie/model-bootstrapping-prognoz-neregulyarnix-/-redkix-prodaj.html
Quote
 
 
#28 Алексей Батурин 23.12.2015 11:09
Цитирую Ирина:
Подскажите, пожалуйста, в формуле я хочу закрепить ячейку/диапазон из условно-форматированной таблицы, соответсвенно она прописывается не как A1 или RC, а например [@[Код клиентской группы]].
Пытаюсь сделать стандартным способом с помощью F4, но выдается ошибка. Я протягиваю формулу и она мне смещает диапазоны.
Заранее спасибо

Ирина, добрый день.
Сделайте обычную ссылку на таблицу формата A1 или RC и ее зафиксируйте.
Quote
 
 
#27 Ирина 23.12.2015 05:32
В добавок к предыдущему вопросу,
сейчас прочитала первый комент, и вы советуете не использовать инструмент таблицы, и писать обычным диапазоном А$1$, а мне именно хочется, что бы в формуле было не имя ячейки/диапазон а (сумм(А$1$:А$4$ )), а именно прописана суть (что как раз достигается если оставить, например =СУММЕСЛИ(Планп родаж[Код клиентской группы];[@[Код клиентской группы]];Планпр одаж[март]), что бы при протягивании на апрель, он мне так и оставлял Планпродаж[Код клиентской группы], а не переходил на Планпродаж[Столбец1].
Спасибо
Quote
 
 
#26 Ирина 23.12.2015 05:24
Подскажите, пожалуйста, в формуле я хочу закрепить ячейку/диапазон из условно-формати рованной таблицы, соответсвенно она прописывается не как A1 или RC, а например [@[Код клиентской группы]].
Пытаюсь сделать стандартным способом с помощью F4, но выдается ошибка. Я протягиваю формулу и она мне смещает диапазоны.
Заранее спасибо
Quote
 
 
#25 Алексей Батурин 19.11.2015 10:04
Цитирую Вера:
Доброго времени суток! Подскажите, как сделать фиксацию на "соседние" столбцы - чтобы при добавлении нового столбца значение в формуле сдвигалось на него? сейчас формула выглядит так: =RC[-2]-RC[-3]. При использовании F4 фиксируются конкретные столбцы...

Вера, добрый день.
Есть такая формула =ИНДЕКС(A2:D6;2 ;3)
в выделенной области "A2:D6"
она всегда будет возвращать ссылку на
2 - строку,
3 - столбец.
Quote
 
 
#24 Вера 19.11.2015 07:47
Доброго времени суток! Подскажите, как сделать фиксацию на "соседние" столбцы - чтобы при добавлении нового столбца значение в формуле сдвигалось на него? сейчас формула выглядит так: =RC[-2]-RC[-3]. При использовании F4 фиксируются конкретные столбцы...
Quote
 
 
#23 Алексей Щукин 22.08.2015 08:59
Понял вас, спасибо.
Quote
 
 
#22 Алексей Батурин 21.08.2015 09:38
Цитирую Алексей Щукин:
При ссылке на лист в другом документе.
Я так понял, что от этого не избавиться. Я прав?

Еще можно заменить "$" -
Нажимаем Ctrl + F
Выбираем "Заменить"
в "Найти" ставим $
в "Заменить на" - оставляем пустым

Нажимаем "Заменить все" и готово!
Quote
 

Добавить комментарий


Защитный код
Обновить